Arabic Chinese simplified Chinese traditional English French German Italian Japanese Korean Spanish

Translation by Google translate

Solved Connect ZWO Asiair to Avalon Linear (Stargo)

More
03 Dec 2020 00:30 #436 by vcastello
Replied by vcastello on topic Connect ZWO Asiair to Avalon Linear (Stargo)
A follow up to my last post (I am still testing when I can).

I have experienced very inconsistent behavior when, during the use of the polar alignment function, the mount is supposed to slew 60 degrees after the initial plate solve while pointing near the NCP. It has only worked correctly once. Most of the time it starts to slew slowly (like at the second or third rate of the hand control slew), then goes at max speed and then stops well before it reaches 60 deg. Some times it doesn't slew at all and once I had to stop the program because the slew kept going way past 60 degrees. Sometimes the number of degrees of slew the ASIAIR Pro app is reporting is correct but most times it stays reading 0. I have the mount controller connected and the mount power supply is running at 15 volts. I have also tried running the mount at 12 volts, but there was no change in the behavior. I can even use the hand controller for the mount to slew it and it works fine. I have to disconnect the mount in the ASIAIR Pro software and slew it manually in order to complete its polar alignment function. The power supply is a new 155Wh Li ion battery pack which can output AC as well as DC and powers everything with no problem.

Please Log in or Create an account to join the conversation.

More
03 Jan 2021 13:27 #456 by tdinneen
Replied by tdinneen on topic Connect ZWO Asiair to Avalon Linear (Stargo)
I have the same issue. As a workaround I don't connect the mount in the ASIAIR app and I manually rotate the RA 60 degrees. Once complete you have to manually bring it back to home. Then connect the scope and away you go. It would be nice if this just worked though without the manual workaround.

Please Log in or Create an account to join the conversation.

More
03 Jan 2021 22:42 #457 by ken.self
Replied by ken.self on topic Connect ZWO Asiair to Avalon Linear (Stargo)
I wonder if this is an artefact of the alignment model in the mount. There are inherently two ways to slew a mount (generically - not just Avalon). One is by activating the motor e.g via handset or virtual handset. The motor runs while the button is pressed and stops when it is released. The other is via a goto command. With the goto command the process is automated within the controller which speeds up and slows down the motors and even makes final small movements to remove backlash. Also, the goto takes into account the alignment model so that after you align the mount (e.g. by platesolving and syncing) your gotos are accurate. Now for Asiair to rotate the mount 60 degrees it can really only do this with a goto since it would not know the slew speed of the mount. So it would add/subtract 4 hours of RA and keep dec the same then do the goto. This creates two problems. The big one is if the alignment model is a long way out, so the goto could go wildly off. Also, the mount would slew in both RA and Dec instead of dec only and this would also adversely affect the alignment algorithm even if it was not so far off. I found this out when writing the SPA module in PHD2. When I automated the slew of the mount using a goto it was moving in both RA and Dec.

-- Ken
Avalon M-Uno; GSO RC8; ASI1600; Optec focuser; Aaeon UP/Ubuntu/INDI

Please Log in or Create an account to join the conversation.